Ocena wątku:
  • 0 głosów - średnia: 0
Object reference not set... - Błąd po wczytaniu save'ów
#1
Witam,
Pojawił się u mnie problem z błędem "object reference not set to an instance of an object" - pojawia się uporczywie co sekundę po wczytaniu dowolnego save'a.
Wszystkie save'y działały bezproblemowo, jednak kiedy po kilku dniach przerwy uruchomiłem grę, każdy save jest już zupełnie niegrywalny. W tym czasie miała miejsce jakaś aktualizacja, która automatycznie pobrała się przy uruchomieniu gry. Nie pobierałem przez te dni żadnych obiektów ani modów. Co więcej, przy włączonych tych samych modach i obiektach, po wczytaniu nowej gry, błąd nie występuje. Błędowi towarzyszy też zjawisko polegające na tym, że przestają działać losowe elektrownie i odcinki wodociągów i linii energetycznych na mapie.

Nie sądzę, żeby problemem były mody, dotąd nie sprawiały problemów, a ich wyłączenie nie powoduje ustąpienia błędu na save'ach. 

Jeśli ktoś ma propozycje rozwiązania problemu, będę niemal dozgonnie wdzięczny, to dość cenne zapisy gry :/
  Odpowiedz
#2
Być może jakiś mod którego używasz jest niekompatybilny z nową wersją gry jednak błędami wyrzuca dopiero po jego użyciu na save-ie, stąd możliwe jest uruchomienie nowej gry bez żadnych problemów. Aby mieć pewność musiałbyś na takiej nowej mapie trochę pograć, pobudować co nieco i dopiero potem, przy kolejnym ładowaniu zobaczyć czy nie wywali błędów. Tutaj: https://docs.google.com/spreadsheets/d/1...w/htmlview# masz listę nieaktualnych modyfikacji, przejrzyj ją i zobacz czy może jakiś mod nie ma swojego zamiennika/nowej wersji albo po prostu jest niezaktualizowany.
Włączenie save-a przy wyłączeniu wszystkich modyfikacji nigdy nie kończy się dobrze i bez znaczenia czy była aktualizacja czy nie wywali ci błędy.
  Odpowiedz
#3
(20-06-2019, 22:24)SZyMeX napisał(a): Być może jakiś mod którego używasz jest niekompatybilny z nową wersją gry jednak błędami wyrzuca dopiero po jego użyciu na save-ie, stąd możliwe jest uruchomienie nowej gry bez żadnych problemów. Aby mieć pewność musiałbyś na takiej nowej mapie trochę pograć, pobudować co nieco i dopiero potem, przy kolejnym ładowaniu zobaczyć czy nie wywali błędów. Tutaj: https://docs.google.com/spreadsheets/d/1...w/htmlview# masz listę nieaktualnych modyfikacji, przejrzyj ją i zobacz czy może jakiś mod nie ma swojego zamiennika/nowej wersji albo po prostu jest niezaktualizowany.
Włączenie save-a przy wyłączeniu wszystkich modyfikacji nigdy nie kończy się dobrze i bez znaczenia czy była aktualizacja czy nie wywali ci błędy.

Dziękuję, spróbuję przetestować to na nowej grze i dam znać. Z tej listy modów używam tylko Image Overlay, nie wiem czemu jest oznaczony jako zepsuty; + More Flags, bo akurat jest w moim przypadku bardzo potrzebny.
EDIT:
Znalazłem jeden stary save z prawie pustą mapą i zbudowałem na nim miasto, wykorzystując większość zasubskrybowanych obiektów i z włączonymi wszystkimi modami. Gra działa dobrze, a save wczytuje się bez problemu i nie wyskakują błędy. Jednak po wczytaniu innych save'ów (na których było już coś więcej zbudowane) wywala ten sam błąd "Object reference...". Bez znaczenia czy jest to save sprzed tygodnia czy kopia zapasowa sprzed paru miesięcy, problem jest ten sam - wyskakujący błąd i brak działania sieci wod./elektr. 
Zastanawiam się - jeśli to save'y zostały uszkodzone - czy mógłbym jakoś uratować część zawartości mapy? Głównie zależy mi na rzeźbie terenu, teksturach, drogach i roślinności (to bardzo nietypowe "miasto"). Jeśli między pojawianiem się błędu uda się kliknąć spację i zatrzymać czas, to można normalnie edytować, błąd wtedy nie wyskakuje.
Jeszcze jedna sprawa - po tej aktualizacji z poziomu gry nie można wyjść do menu głównego ani wczytać innego save'a - od razu wyłącza całkiem grę i wychodzi do pulpitu, może to będzie jakąś wskazówką :/
  Odpowiedz
#4
Podeślij pliki log
  Odpowiedz
#5
(21-06-2019, 13:41)SZyMeX napisał(a): Podeślij pliki log
Proszę:
https://gist.github.com/Kroper17/f229de4...e988b7d6bd
  Odpowiedz
#6
Cytat:Simulation error: Object reference not set to an instance of an object
at Klyte.ServiceVehiclesManager.Overrides.SVMBuildingAIOverrideUtils.getBuildingOverrideExtension (BuildingInfo) <0x00985>
at Klyte.ServiceVehiclesManager.Extensors.VehicleExt.ServiceSystemDefinition.ListAiOverrides (BuildingInfo,Klyte.ServiceVehiclesManager.Extensors.VehicleExt.ServiceSystemDefinition) <0x0005a>
at Klyte.ServiceVehiclesManager.Extensors.VehicleExt.ServiceSystemDefinition.ListAiOverrides (BuildingInfo) <0x00027>
at Klyte.ServiceVehiclesManager.Extensors.VehicleExt.ServiceSystemDefinition.isFromSystem (BuildingInfo) <0x00d20>
at Klyte.ServiceVehiclesManager.Extensors.VehicleExt.ServiceSystemDefinition/<>c__DisplayClass58_0.<from>b__0 (Klyte.ServiceVehiclesManager.Extensors.VehicleExt.ServiceSystemDefinition) <0x0002d>
at System.Linq.Enumerable/<CreateWhereIterator>c__Iterator1D`1<Klyte.ServiceVehiclesManager.Extensors.VehicleExt.ServiceSystemDefinition>.MoveNext () <0x0016b>
at System.Linq.Enumerable.FirstOrDefault<Klyte.ServiceVehiclesManager.Extensors.VehicleExt.ServiceSystemDefinition> (System.Collections.Generic.IEnumerable`1<Klyte.ServiceVehiclesManager.Extensors.VehicleExt.ServiceSystemDefinition>) <0x000dc>
at Klyte.ServiceVehiclesManager.Overrides.TransportStationAIOverrides.CreateIncomingVehicle (bool,TransportStationAI,uint16,Building&,uint16,int) <0x0042e>
at (wrapper dynamic-method) TransportStationAI.CreateIncomingVehicle_Patch1 (object,uint16,Building&,uint16,int) <0x00064>
at TransportStationAI.ProduceGoods (uint16,Building&,Building/Frame&,int,int,Citizen/BehaviourData&,int,int,int,int,int,int) <0x004f7>
at PlayerBuildingAI.SimulationStepActive (uint16,Building&,Building/Frame&) <0x009d5>
at CommonBuildingAI.SimulationStep (uint16,Building&,Building/Frame&) <0x00e6d>
at PlayerBuildingAI.SimulationStep (uint16,Building&,Building/Frame&) <0x0002f>
at DepotAI.SimulationStep (uint16,Building&,Building/Frame&) <0x00035>
at TransportStationAI.SimulationStep (uint16,Building&,Building/Frame&) <0x00180>
at HarborAI.SimulationStep (uint16,Building&,Building/Frame&) <0x000a5>
at BuildingAI.SimulationStep (uint16,Building&) <0x00060>
at TrafficManager.Custom.AI.CustomCommonBuildingAI.CustomSimulationStep (uint16,Building&) <0x000a2>
at BuildingManager.SimulationStepImpl (int) <0x00675>
at SimulationManagerBase`2.SimulationStep (int) <0x0004c>
at BuildingManager.ISimulationManager.SimulationStep (int) <0x00024>
at SimulationManager.SimulationStep () <0x00693>
at SimulationManager.SimulationThread () <0x0018a>

Taki błąd wywala dobre kilkanaście razy na końcu logu. Nie wiem co to za modyfikacja to też za bardzo ci nie pomogę. Albo spróbuj tylko tego moda wyłączyć albo pozmieniać coś w jego opcjach itp. Tu niestety musisz zdać się na siebie, no chyba że ktoś inny będzie wiedział o co chodzi :P

Oprócz tego wcześniej masz błędy typu:

Cytat:d3d11: failed to create 2D texture id=41826 width=1 height=1 mips=3 dxgifmt=29 [D3D error was 80070057]

W takim wypadku spróbuj włączyć grę z opcją uruchamiania "-force-d3d9" (tutaj link do wszystkich opcji + poradnika co i jak: https://steamcommunity.com/sharedfiles/f...=466981085)
Powinno pomóc przynajmniej z tym błędem.
 Podziękowali: Kroper17
  Odpowiedz
#7
EDIT: chodzi o moda Service Vehicle Manager od Klyte'a. Ostatnio autor wprowadził jakieś zmiany do niego i mod zepsuł się zupełnie. Generalnie mod umożliwiał wybór rodzaju pojazdu jaki jest spawnowany z danego budynku. 
Po wyłączeniu moda wszystko działa normalnie! 
Dzięki dobry człowieku, uratowałeś 3 miesiące mojej pracy nad mapą! Niech Ci to Bóg w dzieciach wynagrodzi Duży uśmiech  Albo w czym sobie życzysz.  

Co do drugiego błędu - muszę używać starych sterowników do karty dedykowanej AMD, bo przy nowych oprogramowanie uznaje, że procesor nie spełnia wymagań minimalnych przez co nie włącza w ogóle karty dedykowanej i gra uruchamia się w 3 FPS na samej karcie zintegrowanej. Sprzęt jest źle skonfigurowany i stąd może pochodzić błąd.
  Odpowiedz

Witaj na Cities Skylines PL!
Aby dodać odpowiedź zaloguj się, lub zarejestruj nowe konto

Jedynie zalogowani użytkownicy mogą odpowiadać w wątkach

Szybka rejestracja

Możesz także skorzystać z opcji szybkiej rejestracji za pomocą facebooka.



Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości